Difference between revisions of "Vpnsec Linux install"

From Cncz
Jump to: navigation, search
m
m
Line 57: Line 57:
 
[[Bestand:vpnsec_linux_2.png|400px]]
 
[[Bestand:vpnsec_linux_2.png|400px]]
  
Klik <b><tt>Add</tt></b>, Selecteer IPsec/IKEv2 in de sectie <b><tt>VPN</tt></b>, klik <b><tt>Create</tt></b>
+
Klik <b><tt>Add</tt></b>, selecteer IPsec/IKEv2 in de sectie <b><tt>VPN</tt></b>, klik <b><tt>Create</tt></b>
  
 
[[Bestand:vpnsec_linux_3.png|400px]]
 
[[Bestand:vpnsec_linux_3.png|400px]]

Revision as of 13:34, 25 November 2015

This procedure assumes using NetworkManager.

Install required software:

# aptitude install network-manager-strongswan strongswan-plugin-eap-mschapv2
The following NEW packages will be installed:
  libstrongswan{a} network-manager-strongswan strongswan-ike{a} strongswan-nm{a} strongswan-plugin-eap-mschapv2 
  strongswan-plugin-openssl{a} 
0 packages upgraded, 6 newly installed, 0 to remove and 0 not upgraded.
Need to get 64.5 kB/3,032 kB of archives. After unpacking 13.5 MB will be used.
Do you want to continue? [Y/n/?] y
Get: 1 http://ubuntumirror.science.ru.nl/nl.archive.ubuntu.com/ubuntu/ trusty-updates/main strongswan-plugin-eap-mschapv2 amd64 5.1.2-0ubuntu2.4 [64.5 kB]
Fetched 64.5 kB in 0s (2,945 kB/s)                        
Selecting previously unselected package libstrongswan.
(Reading database ... 761421 files and directories currently installed.)
Preparing to unpack .../libstrongswan_5.1.2-0ubuntu2.4_amd64.deb ...
Unpacking libstrongswan (5.1.2-0ubuntu2.4) ...
Selecting previously unselected package strongswan-nm.
Preparing to unpack .../strongswan-nm_5.1.2-0ubuntu2.4_amd64.deb ...
Unpacking strongswan-nm (5.1.2-0ubuntu2.4) ...
Selecting previously unselected package strongswan-plugin-openssl.
Preparing to unpack .../strongswan-plugin-openssl_5.1.2-0ubuntu2.4_amd64.deb ...
Unpacking strongswan-plugin-openssl (5.1.2-0ubuntu2.4) ...
Selecting previously unselected package strongswan-ike.
Preparing to unpack .../strongswan-ike_5.1.2-0ubuntu2.4_amd64.deb ...
Unpacking strongswan-ike (5.1.2-0ubuntu2.4) ...
Selecting previously unselected package strongswan-plugin-eap-mschapv2.
Preparing to unpack .../strongswan-plugin-eap-mschapv2_5.1.2-0ubuntu2.4_amd64.deb ...
Unpacking strongswan-plugin-eap-mschapv2 (5.1.2-0ubuntu2.4) ...
Selecting previously unselected package network-manager-strongswan.
Preparing to unpack .../network-manager-strongswan_1.3.0-1ubuntu1_amd64.deb ...
Unpacking network-manager-strongswan (1.3.0-1ubuntu1) ...
Processing triggers for man-db (2.6.7.1-1ubuntu1) ...
Setting up libstrongswan (5.1.2-0ubuntu2.4) ...
Setting up strongswan-plugin-openssl (5.1.2-0ubuntu2.4) ...
Setting up strongswan-plugin-eap-mschapv2 (5.1.2-0ubuntu2.4) ...
Setting up strongswan-nm (5.1.2-0ubuntu2.4) ...
Setting up strongswan-ike (5.1.2-0ubuntu2.4) ...
Setting up network-manager-strongswan (1.3.0-1ubuntu1) ...


# service network-manager stop
network-manager stop/waiting
# service network-manager start
network-manager start/running, process 29031

Configuration:

Selecteer het NetworkManager applet en vervolgens Edit Connections...

Vpnsec linux 2.png

Klik Add, selecteer IPsec/IKEv2 in de sectie VPN, klik Create

Vpnsec linux 3.png

|Voer gegevens vpnsec.science.ru.nl,gebruikrsnaam, etc in en zet betreffende vinkjes

Vpnsec linux 4.png

Sla op

Vpnsec linux 5.png

Starten van de VPN

Vpnsec linux 6.png