Difference between revisions of "Ldap adresboek"

From Cncz
Jump to: navigation, search
(Thunderbird)
 
(10 intermediate revisions by 5 users not shown)
Line 1: Line 1:
=== [FNWI adresboek in Outlook/Thunderbird][Faculty of Science address book in Outlook/Thunderbird] ===
+
=== [FNWI adresboek in Outlook/Thunderbird/Squirrel][Faculty of Science address book in Outlook/Thunderbird/Squirrel] ===
  
  
Line 8: Line 8:
 
# Vervolgens selecteer "Een nieuwe adreslijst of een nieuw adresboek toevoegen" en klik op "Volgende"
 
# Vervolgens selecteer "Een nieuwe adreslijst of een nieuw adresboek toevoegen" en klik op "Volgende"
 
# Selecteer "Internetadreslijstservice (LDAP)" en klik op "Volgende"
 
# Selecteer "Internetadreslijstservice (LDAP)" en klik op "Volgende"
# Vul als servernaam in: ldap1.science.ru.nl en klik op "Meer instellingen"
+
# Vul als servernaam in: ldap.science.ru.nl en klik op "Meer instellingen"
 
# Selecteer het Tabblad Zoeken en vul in als Zoekbasis: o=addressbook
 
# Selecteer het Tabblad Zoeken en vul in als Zoekbasis: o=addressbook
 
# en klik op "OK", vervolgens op "Volgende" en tenslotte op "Voltooien"
 
# en klik op "OK", vervolgens op "Volgende" en tenslotte op "Voltooien"
Line 30: Line 30:
 
# Next select "Add a new directory or address book" and click on "Next"
 
# Next select "Add a new directory or address book" and click on "Next"
 
# Select "Internet Directory Service (LDAP)" and click on "Next"
 
# Select "Internet Directory Service (LDAP)" and click on "Next"
# Fill in server name: ldap1.science.ru.nl and click on "More Settings"
+
# Fill in server name: ldap.science.ru.nl and click on "More Settings"
 
# Select the Tab Search and fill in as search base: o=addressbook
 
# Select the Tab Search and fill in as search base: o=addressbook
 
# click on "OK", subsequentlty on "Next" and finally on "Finish"
 
# click on "OK", subsequentlty on "Next" and finally on "Finish"
Line 50: Line 50:
 
[nl]
 
[nl]
 
Indien je een Engelstalige Thunderbird gebruikt bekijk dan de Engelse versie van deze pagina  
 
Indien je een Engelstalige Thunderbird gebruikt bekijk dan de Engelse versie van deze pagina  
# In Thunderbird kies Tools->Address Book
+
# In Thunderbird kies Extra->Adresboek
# Vervolgens kies in het menu File -> New -> Ldap Directory ...
+
# Vervolgens kies in het menu van het Adresboek venster Bestand -> Nieuw -> Ldap-directory ...
# Kies een Name:  bijvoorbeeld FNWI
+
# Kies een Naam:  bijvoorbeeld Science
# Hostname: ldap1.science.ru.nl
+
# Hostnaam: ldap.science.ru.nl
# Base DN:  o=addressbook
+
# Basis DN:  o=addressbook
# Eventueel kun je in het Advanced tab blad het aantal matches groter of kleiner maken (default is 100)
+
# Eventueel kun je in het Geavanceerd tabblad het aantal getoonde resultaten groter of kleiner maken (default is 100)
 
# Sluit af door "OK" te klikken
 
# Sluit af door "OK" te klikken
# Om Autocompletion aan te zetten voor het LDAP adresboek, kies in "Preferences" het "Composition" Tab blad
+
# Om Automatische adresaanvulling aan te zetten voor het LDAP adresboek, kies in het menu Extra "Opties" het "Opstellen" tabblad
# Vervolgens Addressing en vink autocompletion aan bij de Directory Server (Kies FNWI in het drop down menu)
+
# Daarbinnen vervolgens het tabblad Addressering en vink de Directoryserver aan (Kies Science in het drop down menu)
  
en vervolgens zal als je een mail adres begint te typen in een To: veld een lijst te voorschijn komen
+
en vervolgens zal als je een mail adres begint te typen in een Aan: veld een lijst te voorschijn komen
 
met alle matches uit je eigen adresboek EN het LDAP adresboek.
 
met alle matches uit je eigen adresboek EN het LDAP adresboek.
  
 
Als je meerdere LDAP servers wilt raadplegen dan is er de Thunderbird plugin
 
Als je meerdere LDAP servers wilt raadplegen dan is er de Thunderbird plugin
[[https://addons.mozilla.org/nl/thunderbird/addon/5684 Multi LDAP Enabler]] die autocompletion mogelijk maakt uit meerdere LDAP servers tegelijkertijd.
+
[https://addons.mozilla.org/nl/thunderbird/addon/5684 Multi LDAP Enabler] die automatische aanvulling mogelijk maakt uit meerdere LDAP servers tegelijkertijd.
 
   
 
   
 
[/nl]
 
[/nl]
Line 70: Line 70:
 
[en]
 
[en]
 
# In Thunderbird choose Tools->Address Book
 
# In Thunderbird choose Tools->Address Book
# Next choose from the menu File -> New -> Ldap Directory ...
+
# Next choose from the menu in the Address Book window: File -> New -> Ldap Directory ...
# Choose a Name:  for example FNWI
+
# Choose a Name:  for example Science
# Hostname: ldap1.science.ru.nl
+
# Hostname: ldap.science.ru.nl
 
# Base DN:  o=addressbook
 
# Base DN:  o=addressbook
 
# In the Advanced tab you can change the maximum number of returned  matches (default is 100)
 
# In the Advanced tab you can change the maximum number of returned  matches (default is 100)
 
# Close by clicking "OK"
 
# Close by clicking "OK"
 
# To turn on Autocompletion for the LDAP address book, choose in "Preferences" the "Composition" Tab
 
# To turn on Autocompletion for the LDAP address book, choose in "Preferences" the "Composition" Tab
# Then in Addressing  check Autocompletion for the Directory Server (Choose FNWI in the drop down menu)
+
# Then in Addressing  check Autocompletion for the Directory Server (Choose Science in the drop down menu)
  
 
subsequently as soon as you start typing a name in a "To:" field a  list with possible matches will popup
 
subsequently as soon as you start typing a name in a "To:" field a  list with possible matches will popup
Line 83: Line 83:
  
 
If you want to search multiple LDAP servers  then there is a Thunderbird plugin
 
If you want to search multiple LDAP servers  then there is a Thunderbird plugin
[[https://addons.mozilla.org/nl/thunderbird/addon/5684 Multi LDAP Enabler]] that makes autocompletion possible from multiple LDAP servers.
+
[https://addons.mozilla.org/nl/thunderbird/addon/5684 Multi LDAP Enabler] that makes autocompletion possible from multiple LDAP servers.
 
   
 
   
 
[/en]
 
[/en]
  
 +
=== Squirrel (webmail) ===
 +
 +
[nl]
 +
In [http://squirrel.science.ru.nl squirrel] is het LDAP adresboek standaard te gebruiken.
 +
In het "Nieuw Bericht" scherm kun je op "Adressen" klikken en dan zoeken in
 +
je eigen adresboek en tegelijkertijd in het LDAP adresboek.
 +
[/nl]
 +
 +
 +
[en]
 +
The LDAP address book is integrated in [http://squirrel.science.ru.nl squirrel].
 +
In the "Compose" window, click on addresses and you can search simultaneously in your own address book
 +
and the LDAP directory.
 +
[/en]
 +
 +
== OsX 10.7 ==
 +
 +
[nl]
 +
Open je adresboek.
 +
Bij voorkeuren (Cmd+,) ga naar Accounts en klik op het plusje rechtsonder.
 +
# Bij Account type, kies voor: LDAP
 +
# Server address: ldap.science.ru.nl
 +
# Klik op Continue.
  
 +
# Description: vrije keuze (kies bijvoorbeeld Science)
 +
# Search base: o=addressbook
 +
# Scope: Subtree, Authentication: None.
 +
# Klik op Create.
 +
 +
Bij View-Groups (Cmd+3) zie je nu je nieuwe directory.
 +
[/nl]
 +
 +
[en]
 +
Open addressbook.
 +
# In Preferences (Cmd+,) go to Accounts and click on the plus at the bottom right.
 +
# At Account type, choose: LDAP
 +
# Server address: ldap.science.ru.nl
 +
# Click Continue.
 +
 +
# Description: your choice (e.g. Science)
 +
# Search base: o=addressbook
 +
# Scope: Subtree, Authentication: None.
 +
# Click Create.
 +
 +
At View-Groups (Cmd+3) you will see your new directory.
 +
[/en]
  
 
[[Category:Email]]
 
[[Category:Email]]

Latest revision as of 12:32, 20 December 2018

Faculty of Science address book in Outlook/Thunderbird/Squirrel

Outlook

  1. In Outlook choose Tools->Email Accounts
  2. Next select "Add a new directory or address book" and click on "Next"
  3. Select "Internet Directory Service (LDAP)" and click on "Next"
  4. Fill in server name: ldap.science.ru.nl and click on "More Settings"
  5. Select the Tab Search and fill in as search base: o=addressbook
  6. click on "OK", subsequentlty on "Next" and finally on "Finish"
  7. Close Outlook and start it again.

You can now search in this address book but a more convenient construction is the following: start a new mail message and fill in part of the name in the "To:" field and press "Control-K". A list of names will popup that match the typed text, choose the name you were looking for.

Unfortunately Outlook stops searching the address books as soon as it has a match in one address book. This implies that if LDAP is the second address book and you have a contact that matches in your personal address book you will not get results from the LDAP address book. In that case only explicitly searching in the LDAP address book will work, you can add the found results to you personal address book so the next time it will find it there.

Thunderbird

  1. In Thunderbird choose Tools->Address Book
  2. Next choose from the menu in the Address Book window: File -> New -> Ldap Directory ...
  3. Choose a Name: for example Science
  4. Hostname: ldap.science.ru.nl
  5. Base DN: o=addressbook
  6. In the Advanced tab you can change the maximum number of returned matches (default is 100)
  7. Close by clicking "OK"
  8. To turn on Autocompletion for the LDAP address book, choose in "Preferences" the "Composition" Tab
  9. Then in Addressing check Autocompletion for the Directory Server (Choose Science in the drop down menu)

subsequently as soon as you start typing a name in a "To:" field a list with possible matches will popup from your own address book AND the LDAP address book.

If you want to search multiple LDAP servers then there is a Thunderbird plugin Multi LDAP Enabler that makes autocompletion possible from multiple LDAP servers.

Squirrel (webmail)


The LDAP address book is integrated in squirrel. In the "Compose" window, click on addresses and you can search simultaneously in your own address book and the LDAP directory.

OsX 10.7

Open addressbook.

  1. In Preferences (Cmd+,) go to Accounts and click on the plus at the bottom right.
  2. At Account type, choose: LDAP
  3. Server address: ldap.science.ru.nl
  4. Click Continue.
  1. Description: your choice (e.g. Science)
  2. Search base: o=addressbook
  3. Scope: Subtree, Authentication: None.
  4. Click Create.

At View-Groups (Cmd+3) you will see your new directory.